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1.  About GFI MailArchiver 

1.1  Introduction to GFI MailArchiver 

GFI MailArchiver is an email archiving solution which can archive all 
internal and external email into a central archive store. You can then 
easily manage the email Archive Stores from the web-based 
configuration of GFI MailArchiver. You can also allow users to browse 
and search past emails via the web-based browse and search 
interface. GFI MailArchiver also provides Microsoft Outlook 
integration. 

1.2  How does GFI MailArchiver work? 

GFI MailArchiver operations can be classified in three stages: 

Stage 1: Retrieve emails from Microsoft Exchange Server 

Stage 2: Archive emails to an Archive Store 

Stage 3: Browse archived emails 

 
Figure 1 - Typical GFI MailArchiver installation 

Stage 1: Retrieve emails 

GFI MailArchiver connects to the journaling mailbox on the Microsoft 
Exchange Server and collects the emails. 

Stage 2: Archive emails 

GFI MailArchiver archives the collected emails to the active database 
configured, for example Microsoft SQL Server. 

Stage 3: Browse archived emails 
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Users can browse and search for specific archived emails via the GFI 
MailArchiver web interface, using Microsoft Internet Explorer. 

1.3  GFI MailArchiver licensing scheme 

For information on GFI MailArchiver licensing, refer to: 

http://www.gfi.com/products/gfi-mailarchiver/pricing/licensing 

 

http://www.gfi.com/products/gfi-mailarchiver/pricing/licensing


 

GFI MailArchiver for Exchange - Getting Started Guide System requirements  3 

2.  System requirements 

2.1  Software 

Supported operating systems 

GFI MailArchiver can be installed on: 

 Microsoft Windows Server 2008 

 Microsoft Small Business Server (SBS) 2008 

 Microsoft Windows Server 2003 

 Microsoft Small Business Server (SBS) 2003 

 Microsoft Windows Server 2000 (Service Pack 3 or higher) 

NOTE: The server on which GFI MailArchiver is installed needs to be 
a Domain Controller or connected to one, since GFI MailArchiver 
requires access to Active Directory. 

Supported mail servers 

 Microsoft Exchange Server 2000 (SP3) or later. 

Supported databases 

 Firebird database - An open source database used as the default 
GFI MailArchiver database. Recommended for organizations with 
less than 25 email users and with moderate amounts of email. 
Bundled with and automatically configured by GFI MailArchiver. 

 Microsoft SQL Server 2000 or later - Highly recommended for 
organizations with more than 25 email users. Not included with 
GFI MailArchiver installation and is required to be installed as a 
separate process. 

Other required components 

 Microsoft .NET Framework 2.0 

 ASP.Net 2.0 

 Internet Information Services (IIS) 5.0 or later - SMTP & World 
Wide Web services 

 Microsoft Internet Explorer 5.5 or later. 

NOTE: Other web browsers such as Mozilla Firefox or Google 
Chrome may limit the functionality of GFI MailArchiver and/or 
impair the user interface. 

 Microsoft Data Access Components (MDAC) 2.6 or higher  

 When GFI MailArchiver is NOT installed on the Microsoft 
Exchange server, Microsoft Exchange Server MAPI Client and 
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Collaboration Data Objects 1.2.1 must be installed on the GFI 
MailArchiver server. Download the Microsoft Exchange Server 
MAPI Client and Collaboration Data Objects 1.2.1 from: 

http://www.microsoft.com/downloads/details.aspx?FamilyID=E17E
7F31-079A-43A9-BFF2-0A110307611E&displaylang=en 

2.2  Hardware 

Processor 

 Minimum: Intel Pentium or compatible - 2GHz 32 bit processor. 

 Recommended: x64 architecture-based server with Intel 64 
architecture or AMD64 platform. 

Memory 

 Minimum: 512MB RAM (dedicated to GFI MailArchiver) 

 Recommended: 2GB RAM (dedicated to GFI MailArchiver) 

Physical Storage 

 Minimum: 150MB physical disk space (NTFS) for GFI 
MailArchiver installation. More space is required for the database 
(Firebird or SQL server). Storage space depends on mail volume 
to archive. 

 Recommended: Server with 4 physical drives, with the ability to 
increase storage space on demand when required. Refer to 
Installation pre-requisite: Setup database section starting on page 
24 in this manual for recommendations on how to set up your 
database. 

NOTE: It is highly recommended that you store databases and 
indexes on separate, appropriately sized hard disks. SCSI hard disks 
are highly recommended. 

2.3  Important settings 

2.3.1  Antivirus and backup software 

Anti-virus and backup software may cause GFI MailArchiver to 
malfunction. This occurs when such software denies access to certain 
files required by GFI MailArchiver. 

Disable any third party anti-virus and backup software from scanning 
the following folders and subfolders: 

 

GFI MailArchiver folders 

<GFI MailArchiver Installation folder> 

<..\Program Files\Common Files\GFI> 

 

Also, exclude the index and the archive store locations from backups 
and anti-virus scans. The default index and archive store locations 
are: 

 

GFI MailArchiver default index and archive store locations 

<GFI MailArchiver Installation folder>\Indexes\default 

<GFI MailArchiver Installation folder>\Databases\default\>   

http://www.microsoft.com/downloads/details.aspx?FamilyID=E17E7F31-079A-43A9-BFF2-0A110307611E&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=E17E7F31-079A-43A9-BFF2-0A110307611E&displaylang=en
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NOTE: You can change the index and archive store locations after 
installing GFI MailArchiver. For information refer to the Configure 
archive stores (starting on page 32) and Configure search indexes 
(starting on page 34) sections in this manual. 

2.3.2  Firewall port settings 

Your firewall may need to be configured to allow connections from the 
GFI MailArchiver Server on the following ports:  

Listening Ports on the GFI MailArchiver Server: 

 Remoting (Ports 8014, 8017, 8018, 8019, 8020) - Used for 
communication between GFI MailArchiver components when 
installed in a role based setup. 

Connections established from the GFI MailArchiver Server   

 SMTP (Port 25) - Used by GFI MailArchiver when an email needs 
to be restored to a user’s mailbox or a notification is sent to the 
GFI MailArchiver Administrator. 

 HTTP (Port 80) - Used by the GFI MailArchiver user interface and 
web services. 

 MAPI/RPC (Port 135) - Used when GFI MailArchiver is installed 
on the same machine as Microsoft Exchange and configured to 
use ExOLEDB to retrieve emails. 

 IMAP (Port 143) - Used to retrieve emails when GFI MailArchiver 
is not installed on the same server as Microsoft Exchange server. 

 Microsoft SQL Server (Port 1443) - Used when GFI MailArchiver 
is configured to archive emails to a Microsoft SQL Server 
Database. 

 Microsoft Global Catalog (Port 3268) - Used for connections 
done from the GFI MailArchiver Server to the Domain Controller 
which stores the Microsoft Global Catalog 

 <Optional> Ports 8096 to 8099 - Used by the GFI PST exporter 
to communicate with GFI MailArchiver when exporting data from 
networked computers. 

2.3.3  Database settings 

Microsoft SQL server settings 

GFI MailArchiver requires Microsoft SQL server (if used as the 
archival database) to be installed in case insensitive mode. 

This is the default installation setting of Microsoft SQL server. The 
Microsoft SQL server collation modes apply to all Microsoft SQL 
server objects including login names. In such cases if a user changes 
a property in the name and does not make EXACT character case 
matches, GFI MailArchiver will fail since it would not find the resources 
required. 

Once installed, it is not possible to change the Microsoft SQL server 
collation mode easily. It requires a rebuild of the master database 
using advanced Microsoft SQL specific tools or methods. The best 
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solution is to install another instance of Microsoft SQL Server (set to 
operate in insensitive collation mode). 

2.3.4  ASP.NET settings 

For GFI MailArchiver to work, ASP.NET needs to be registered with 
IIS and enabled from IIS.  

Register ASP.NET with IIS 

If the Microsoft .NET framework is installed after IIS is installed this is 
automatically registered. Else, register ASP.NET with IIS by following 
these steps:  

1. From the command prompt, navigate to: 

<WindowsDirectory>\Microsoft.NET\Framework\<v2.0.xx

xxx>\ 

NOTE: Replace v2.0.xxxxx with the folder name of .NET 

Framework version number. 

Example: 

C:\Windows\Microsoft.NET\Framework\v2.0.50727\ 

2. Key in aspnet_regiis.exe -i and press Enter. 

 
Screenshot 1 - Registering ASP.NET with IIS 

Enable ASP.NET from IIS 

Ensure that ASP.NET is allowed by Internet Information Services (IIS) 
Manager. 

IIS 6 

1. Navigate to Control Panel ► Administrative Tools ► 
Internet Information Services (IIS) Manager. 

2. Expand the local computer node and select Web Service 
Extensions.  

3. In the right pane, right click ASP.NET v2.0.xxxxx and select 
Allow. 

IIS 7 

1. Navigate to Control Panel ► Administrative Tools ► 
Internet Information Services (IIS) Manager. 

2. Select the local computer node and from the Features View 
pane launch ISAPI and CGI Restrictions. 

3. In the Features View pane, right click ASP.NET v2.0.xxxxx and 
select Allow 
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3.  New Installations 

3.1  Where should GFI MailArchiver be installed? 

Install GFI MailArchiver on a machine that is part of an Active 
Directory domain. Before proceeding with the installation, first 
consider the following details: 

 Email volume on your servers - Installing GFI MailArchiver on a 
mail server where a high volume of emails received and 
processed will invariably put more load on server resources. This 
can cause these servers to become unresponsive and not process 
mail in a timely fashion. 

 Hardware and software specifications of your servers - The 
hardware and software specifications listed in the System 
requirements section above should be considered to be over and 
above the requirements of other software installed on the same 
server. Servers which are nearing their capacity in terms of 
resources should not be used to install GFI MailArchiver. 

 Need to archive email from multiple sources concurrently - 
Installing GFI MailArchiver on a server which is not granted access 
to multiple sources creates a problem in the centralization efforts 
of email data archival. 

If all of the above details are considered not to be of significant issues 
then you can consider installing GFI MailArchiver on the mail server. 

Example: 

 If you need to archive email from one Microsoft Exchange Server, 
and the server is handling the email flow on your network and still 
has spare processing capacity, then you can consider installing 
GFI MailArchiver on the Microsoft Exchange Server machine 
directly. 

 If you want to archive email from multiple Microsoft Exchange 
servers using IMAP, it is recommended that you install GFI 
MailArchiver on a separate server. 

GFI MailArchiver does not require a dedicated machine when it is not 
installed on the mail server. 

Example: 

 Install GFI MailArchiver on machines running other applications 
such as GFI MailEssentials or GFI MailSecurity. 
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3.2  Installation pre-requisite: Enable Journaling 

3.2.1  Setting up Journaling for Microsoft Exchange Server 
2000/2003 

Journaling is a feature that enables the recording of all email in an 
organization. Microsoft Exchange journaling enables the channeling of 
data into an archival solution with minimum overhead. 

While, by definition, journaling is the ability to record emails, archival 
reduces the strain of storing data through backups, removal, and 
storage. GFI MailArchiver uses Microsoft Exchange journaling to 
centralize all the emails to archive in a single mailbox. 

NOTE: If journaling is not set up correctly, email archiving will NOT 
work. 

Step 1: Create a new journaling mailbox. 

1. Select Start ► Programs ► Microsoft Exchange ► Active 
Directory Users and Computers. 

 
Screenshot 2 - Add new user in Microsoft Exchange 2003 

2. Expand the domain to archive emails from, right-click Users node 
and select New ► User. 
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Screenshot 3 - New Object - User dialog 

3. Key in a relevant ‘User logon name’ (e.g. journal), fill in other new 
user details, and click Next. 

 
Screenshot 4 - Add a password 

4. Key in a password, unselect user must change password at next 
logon option and enable user cannot change password and 
password never expires options. Click Next to continue setup. 
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NOTE: Ensure that the password keyed in meets the password 
complexity requirements setup for your Active Directory users. 

5. Click Next and review the new user details. Click Finish to create 
new user. 

Step 2: Configure email archival to journaling mailbox 

1. Select Start ► Programs ► Microsoft Exchange ► System 
Manager. 

 
Screenshot 5 - Mailbox store node properties 

2. Expand Servers ► <Your Server name> ► Storage group, right 
click Mailbox Store node and select Properties. 
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Screenshot 6 - Enabling journaling on a Microsoft Exchange mailbox store 

3. From the General tab, select the Archive all messages sent or 
received by mailboxes on this store check box and click Browse 
button. 

4. Select the journaling mailbox name you created in step one, for 
example ‘journal’, and click OK. 

5. Close the Mailbox Store Properties dialog and the Exchange 
System Manager Management console. 

Step 3: Enable BCC information journaling 

IMPORTANT NOTE: It is highly recommended that you DO NOT 
enable this option but enable envelope journaling instead. Envelope 
journaling journals all the header information, not just the BCC data. 
For more information on envelope journaling refer to Step 4: Enable 
Envelope Journaling 

On Microsoft Exchange Server 2000 and Microsoft Exchange Server 
2003 systems, BCC information is not by default included in the 
journaled message. To enable BCC information journaling: 

For Microsoft Exchange Server 2000 only 

1. Install hot fix available from: 

http://support.microsoft.com/?kbid=810999 

For both Microsoft Exchange Server 2000 and Microsoft 
Exchange Server 2003. 

1. From command prompt, type regedit.exe 

http://support.microsoft.com/?kbid=810999
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2. Add the following registry key: 

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSEx
changeTransport\Parameters 

3. Add the following registry key and values: 

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSEx
changeTransport\Parameters\ 

 Key name: JournalBCC 

 Data type: Dword 

 Data value: 1 

4. Close Registry editor and from command prompt type 
services.msc. Restart Simple Mail Transport Protocol and the 
Information Store services. 

Step 4: Enable Envelope Journaling 

Envelope Journaling enables the archival of email header information 
and can be switched on using: 

 Microsoft Exchange Server Email Journaling Advanced 
Configuration (exejcfg.exe), or 

 ADSI Editor Management console. 

Using the exejcfg.exe tool 

1. Download the exejcfg.exe tool from: 

http://www.microsoft.com/downloads/details.aspx?familyid=E7F73F10
-7933-40F3-B07E-EBF38DF3400D&displaylang=en 

2. From the command prompt, navigate to the folder in which you 
copied the exejcfg.exe tool. 

3. Type exejcfg -e and press Enter. 

NOTE: exejcfg -d disables Envelope Journaling for that organization. 

Using the ADSI editor 

1. Locate the adsiedit.msc tool from the Windows 2000 Server 
resource kit or the Windows 2003 Server support tools. 

2. From command prompt, navigate to the folder where adsiedit.msc 
is stored, type adsiedit.msc and then press Enter. 

http://www.microsoft.com/downloads/details.aspx?familyid=E7F73F10-7933-40F3-B07E-EBF38DF3400D&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=E7F73F10-7933-40F3-B07E-EBF38DF3400D&displaylang=en
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Screenshot 7 - ADSI Edit 

3. Expand ADSI Edit ► Configuration ► <CN=Configuration> ► 
<CN=Services> ► <CN=Microsoft Exchange> node. 

4. Right-click CN<your organization name> node and click 
Properties. 



 

14  New Installations GFI MailArchiver for Exchange - Getting Started Guide 

 
Screenshot 8 - Heuristics attribute 

5. Select heuristics attribute from the Attributes list and click Edit. 

 
Screenshot 9 - Editing the heuristics attribute value 

6. Key in ‘512’ and click OK. 

7. Click OK to save and close the ADSIEdit console. 

Note: A value of 512 enables Envelope Journaling, and a value of 0 
disables Envelope Journaling. 
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3.2.2  Setting up journaling for Microsoft Exchange Server 
2007 

Journaling is a feature that enables the recording of all email in an 
organization. Microsoft Exchange journaling enables the channeling of 
data into an archival solution with minimum overhead. 

While, by definition, journaling is the ability to record emails, archival 
reduces the strain of storing data through backups, removal, and 
storage. GFI MailArchiver uses Microsoft Exchange journaling to 
centralize all the emails to archive in a single mailbox. 

NOTE: If journaling is not set up correctly, email archiving will NOT 
work. 

Microsoft Exchange 2007 supports two types of journaling: 

 Standard journaling: This feature enables the configuration of a 
Mailbox store that enables the recording of email in an 
organization. GFI MailArchiver can use Microsoft Exchange 
journaling to centralizer all the emails to archive in a single 
mailbox for archival. This type of journaling is also called per-
mailbox database journaling. 

 Premium journaling: Only available with the Microsoft Exchange 
Enterprise client access license. It enables an administrator to 
setup custom journaling rules such as: 

o Archive only incoming emails 

o Archive only outgoing emails 

o Archive emails for a particular group. 

This journaling is also called per-recipient journaling. 

GFI MailArchiver utilizes this type of journaling by detecting and 
displaying these rules in the Data Sources Configuration Wizard. 

NOTE: If journaling is not set up correctly, email archiving will NOT 
work. 

Which journaling method shall I use? 

Choose standard journaling to archive all emails (inbound and 
outbound) for all users in your organization. 

Choose premium journaling of you want more control over the emails 
to archive (e.g. only for specific users or for inbound or outbound 
only). Note that premium journaling requires a Microsoft Exchange 
Enterprise client access license. 

Set up standard journaling 

Step 1: Create a new journaling mailbox 

1. Select Start ► All Programs ► Microsoft Exchange Server 2007 
► Microsoft Exchange Management Console. 

2. Expand Recipient Configuration node and click on Mailbox node. 

3. Select New Mailbox… from the Actions pane. 

4. Select User Mailbox option and click Next. 

5. Select New user option and click Next. 
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Screenshot 10 - New user mailbox details 

6. Key in the ‘User information’ details for the new user to which the 
new journaling mailbox will be assigned and click Next. 

7. Ensure that the mailbox settings are correct and click Next. 

8. Review the new mailbox summary for the new mailbox to create 
and click New. 

Step 2: Configure standard journaling 

1. Select Start ► All Programs ► Microsoft Exchange Server 2007 
► Microsoft Exchange Management Console. 
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Screenshot 11 - Configuring a Mailbox Database 

2. Expand Microsoft Exchange ► Server Configuration ► Mailbox 
node and click Properties from the Actions pane. 

 
Screenshot 12 - Mailbox Database properties 
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3. Select Journal Recipient option, click Browse, and select mailbox 
previously configured from the Active Directory. 

4. Click OK to finalize setup. 

Set up premium journaling 

1. Select Start ► All Programs ► Microsoft Exchange Server 2007 
► Microsoft Exchange Management Console. 

 
Screenshot 13 - Configuring Journaling rules 

2. Expand Organization Configuration ► Hub Transport node and 
select Journaling tab. 

3. From the Actions tab and click on New Journaling Rule. 
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Screenshot 14 -Creating a new Journaling rule 

4. Key in a name for the new rule and click Browse. Select the 
Journal e-mail address, preferably a mailbox within the existing 
Microsoft Exchange organization, from Active Directory. 

5. <Optional> Configure: 

 Scope - Select whether to journal all email (Global), internal or 
external email. 

 Journal e-mail for recipient - Select specific recipient(s) for 
which this journaling rule applies. 

6. Ensure that the Enable Rule option is enabled and click New. 

NOTE: In Microsoft Exchange Server 2007, envelope journaling is 
automatically enabled by default. 

3.2.3  Setting up journaling for Microsoft Exchange Server 
2010 

Journaling is a feature that enables the recording of all email in an 
organization. Microsoft Exchange journaling enables the channeling of 
data into an archival solution with minimum overhead. 

While, by definition, journaling is the ability to record emails, archival 
reduces the strain of storing data through backups, removal, and 
storage. GFI MailArchiver uses Microsoft Exchange journaling to 
centralize all the emails to archive in a single mailbox. 

NOTE: If journaling is not set up correctly, email archiving will NOT 
work. 

Microsoft Exchange 2010 supports two types of journaling: 

 Standard journaling: This feature enables the configuration of a 
Mailbox store that enables the recording of email in an 
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organization. GFI MailArchiver can use Microsoft Exchange 
journaling to centralize all the emails to archive in a single mailbox 
for archival. This type of journaling is also called per-mailbox 
database journaling. 

 Premium journaling: Only available with the Microsoft Exchange 
Enterprise client access license. It enables an administrator to 
setup custom journaling rules such as: 

o Archive only incoming emails 

o Archive only outgoing emails 

o Archive emails for a particular group. 

GFI MailArchiver utilizes this type of journaling by detecting and 
displaying these rules in the Data Sources Configuration Wizard. 

NOTE: If journaling is not set up correctly, email archiving will NOT 
work. 

Which journaling method shall I use? 

Choose standard journaling to archive all emails (inbound and 
outbound) for all users in your organization. 

Choose premium journaling of you want more control over the emails 
to archive (e.g. only for specific users or for inbound or outbound 
only).  

NOTE: Premium journaling requires a Microsoft Exchange Enterprise 
client access license. 

Set up standard journaling 

Step 1: Create a new journaling mailbox 

1. Launch Microsoft Exchange Management Console. 

2. Expand Recipient Configuration node and click on Mailbox node. 

3. Select New Mailbox… from the Actions pane. 

4. Select User Mailbox option and click Next. 

5. Select New user option and click Next. 
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Screenshot 15 - New user mailbox details 

6. Key in the ‘User information’ details for the new user to which the 
new journaling mailbox will be assigned and click Next. 

7. Enter an ‘Alias’ for the journaling mailbox and click Next. 

8. Click Next and review the new mailbox summary for the new 
mailbox to create and click New. 

Step 2: Configure standard journaling 

1. Launch Microsoft Exchange Management Console. 
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Screenshot 16 - Configuring a Mailbox Database 

2. Expand Microsoft Exchange ► Organization Configuration ► 
Mailbox node. Right-click the Mailbox database and select 
Properties. 
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Screenshot 17 - Mailbox Database properties 

3. From the mailbox database properties dialog, select the 
Maintenance tab and select the Journal Recipient checkbox. Click 
Browse, and select the journaling mailbox previously configured. 

4. Click OK to finalize setup. 

Set up premium journaling 

1. Launch Microsoft Exchange Management Console. 

2. Expand Organization Configuration ► Hub Transport node and 
select Journaling tab. 

3. From the Actions tab, click New Journal Rule. 



 

24  New Installations GFI MailArchiver for Exchange - Getting Started Guide 

 
Screenshot 18 -Creating a new Journaling rule 

4. Key in a name for the new rule 

5. Click Browse to select the journaling mailbox where to send journal 
reports.  

6. <Optional> Configure: 

 Scope - Select whether to journal all email (Global), internal or 
external email. 

 Journal messages for recipient - Select specific recipient(s) for 
which this journaling rule applies. 

7. Ensure that the Enable Rule option is enabled and click New. 

NOTE: In Microsoft Exchange Server 2010, envelope journaling is 
automatically enabled by default. 

3.3  Installation pre-requisite: Setup database 

As an archiving solution, GFI MailArchiver is highly dependent on your 
database infrastructure setup for high performance in terms of data 
archival and retrieval. 

3.3.1  Choosing your database backend 

GFI MailArchiver can be configured to run in various hardware setups 
and combinations. The table below shows the typical recommended 
configurations. These guidelines and configurations may vary 
according to user activity and daily email flow. 
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Seats Outlook 
Connector + 
Folder Sync 

MS Exchange Firebird MS SQL 

 Local Remote  Local Remote 

<50       

51-100 
      

      

101-150 
      

      

150-200       

200+       

Examples 

 Example 1:  

Network with 51-100 seats and with GFI Outlook Connector and 
user mailbox folder synchronization:  

GFI MailArchiver installation location should be on a different 
server than Microsoft Exchange Server. Firebird database used as 
database. 

 Example 2:  

Network with 101-150 sears without GFI Outlook Connector and 
user mailbox folder synchronization:  

Install GFI MailArchiver on the same server as Microsoft Exchange 
and Firebird database. 

 Example 3:  

Network with over 200 seats:  

Install GFI on a different server other than Microsoft Exchange and 
Microsoft SQL Server. Do not use Firebird database 

NOTE 1: 200+ seats does not mean that if the you have 1000 
seats, the same configuration can be used. In this context, 200+ 
can be understood as 200-500.  It is however always important to 
consider distributed deployment in cases of high email flow. 

3.3.2  Configuring the Firebird database 

GFI MailArchiver ships with a Firebird database. This database should 
meet the needs of organizations with few email users and an average 
volume of emails. 

NOTE: Ensure that the size of each Firebird database never exceeds 
2GB. 

To minimize any potential performance issues, the following setup is 
strongly recommended when using the Firebird database: 

 Physical HDD 1: Operating System and GFI MailArchiver 
installation. 
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 Physical HDD 2: Firebird database data store. 

 Physical HDD 3: Mail database indexes. 

The above setup reduces data read/write operations on the same 
physical hard disk drive to improve performance.  

Important note: Failing to follow the above recommendations may 
result in substantial performance degradation. 

3.3.3  Configuring the Microsoft SQL Server 

Setting up a Microsoft SQL server is recommended for larger 
organizations or a substantial volume of emails to archive. 

The recommended setup for GFI MailArchiver using a Microsoft SQL 
Server 2000/2005/2008 database is as follows: 

 Physical HDD 1: Operating System and GFI MailArchiver 
installation. 

 Physical HDD 2: Microsoft SQL Server data file (.mdf). 

 Physical HDD 3: Microsoft SQL Server log file (.ldf) 

 Physical HDD 4: Mail database indexes. 

This configuration ensures that different processes are distributed to 
distinct physical hard disk drives. This eliminates performance loss 
due to excessive data read/write operations on the same physical 
hard disk drive. 

Using Microsoft SQL Express 

GFI MailArchiver can be used together with Microsoft SQL Express as 
a lower cost alternative to the full version Microsoft SQL Server. There 
are however a number of Microsoft SQL Server limitations to consider: 

 Database size can be up to 4GB. 

 It uses 1 CPU only. 

 It uses a maximum of 1GB RAM. 

It is therefore highly recommended that: 

1. Use MS SQL and file system as the backend database. This 
method uses Microsoft SQL Express as the backend database and a 
separate location (not a database) for the binary sources files. This 
saves up on the Microsoft SQL Express space required for archiving.  

Refer to the GFI MailArchiver manual (installed with GFI MailArchiver) 
for detailed information on Archive Stores. 

2. Enable the Use a new Archive Store when full feature within 
Archive Store Management. This instructs GFI MailArchiver to 
automatically switch to a new database when the 4GB limit of 
Microsoft SQL Express is reached. This feature requires that Archive 
Stores are based on SQL and Filesystem. 

Refer to the GFI MailArchiver manual (installed with GFI MailArchiver) 
for detailed information on the Use a new Archive Store when full 
feature within Archive Store Management 

3. Monitor database growth on a periodical basis to gain an estimate 
of how long it will take the SQL Express database to reach its 4 GB 
limit. Using this estimate create enough databases and Archive stores 
to cater for your requirements. 
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Important Notes for all Microsoft SQL installations 

1. Configure any Microsoft SQL Server to use Mixed Authentication 
mode for use it with GFI MailArchiver. Achieve this by: 

 Right-click on the SQL Server node ► Properties from 
the Enterprise Manager 

 Access Security tab and select SQL Server and Windows under 
Authentication. 

 Save settings. 

2. After the first month of archiving, note the database data file size. 
With this value, estimate the archive database size after six months, 
for example. If you estimate that your archive database will be larger 
than 20 GB, you should consider configuring the Archive Stores 
management feature of GFI MailArchiver. 

3. Ensure that Journaling is enabled on Microsoft Exchange Server. 

Creating databases 

Microsoft SQL Server 2000  

1. Select Start ► All Programs ► Microsoft SQL Server 2000 ► 
SQL Management Studio. 

2. Expand the SQL Server node where you want to create the 
database. 

3. Right-click Databases node, and click New Database. 

4. <Optional> Customize the following values for performance: 

 Pre-allocate space for both the data and transaction (log) files, 
(e.g. 500 MB for data file, and 50MB for transaction file). 

 Set file growth for both data and transaction (log) files to a fixed 
value in megabytes, not more than 100 MB. 

 Ensure that Maximum file size option is set to Unrestricted file 
growth for both data and transaction (log) files. 

5. Key in a name for the new database in the Name box, for example, 
'MailArchiver', and click OK. 
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Microsoft SQL Server 2005 

Important Note: If you are using Microsoft SQL Express, download 
the Microsoft SQL Server Management Studio Express from: 

http://www.microsoft.com/downloads/details.aspx?familyid=C243A5A
E-4BD1-4E3D-94B8-5A0F62BF7796&displaylang=en 
 

1. Select Start ► All Programs ► Microsoft SQL Server 2005 ► 
SQL Management Studio. 

2. Right click Databases node and select New Database… 

3. Key in a name for the new database in the Database name field, for 
example, ‘MailArchiver’. 

4. <Optional> Customize the following values for performance: 

 Pre-allocate space for both the data and transaction (log) files, 
(e.g. 500 MB for data file, and 50MB for transaction file). 

 Set file growth for both data and transaction (log) files to a fixed 
value in megabytes, not more than 100 MB. 

 Ensure that Maximum file size option is set to Unrestricted file 
growth for both data and transaction (log) files. 

5. Click OK to finalize setup. 

Microsoft SQL Server 2008 

Important Note: If you are using Microsoft SQL Express, download 
the Microsoft SQL Server Management Studio Express from: 

http://www.microsoft.com/downloads/details.aspx?familyid=08E52AC2
-1D62-45F6-9A4A-4B76A8564A2B&displaylang=en 

1. Select Start ► All Programs ► Microsoft SQL Server 2008 ► 
SQL Management Studio. 

2. From the Object Explorer, connect to an instance of the SQL Server 
Database Engine and then expand that instance. 

3. Right-click Databases, and click New Database. 

4. In New Database, enter a database name. 

5. <Optional> Customize the following values for performance: 

 Pre-allocate space for both the data and transaction (log) files, 
(e.g. 500 MB for data file, and 50MB for transaction file). 

 Set file growth for both data and transaction (log) files to a fixed 
value in megabytes, not more than 100 MB. 

 Ensure that Maximum file size option is set to Unrestricted file 
growth for both data and transaction (log) files. 

6. Click OK to finalize setup. 

3.4  Installation pre-requisite: Enable IMAP  

IMAP is required when GFI MailArchiver is not installed on the same 
machine running Microsoft Exchange Server. The IMAP service is 
needed to access the ‘Journaling mailbox’ (refer to glossary for more 
information) on the remote Microsoft Exchange Server. 

By default IMAP service is disabled. To enable: 

1. Click Start ► Run and type „Services.msc‟. 

http://www.microsoft.com/downloads/details.aspx?familyid=C243A5AE-4BD1-4E3D-94B8-5A0F62BF7796&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=C243A5AE-4BD1-4E3D-94B8-5A0F62BF7796&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=08E52AC2-1D62-45F6-9A4A-4B76A8564A2B&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=08E52AC2-1D62-45F6-9A4A-4B76A8564A2B&displaylang=en
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Screenshot 19 - Enabling the IMAP service 

2. Locate the ‘Microsoft Exchange IMAP4’ service. Right-click on the 
service and select Properties. 

3. Select Automatic from the Startup type drop-down provided, click 
Apply, and click Start. 

4. Click OK to save settings and close the dialog. Confirm that the 
service is now running. 

5. By default, on Microsoft Exchange Server 2007/2010, IMAP uses 
SSL to secure the connection. To use simple authentication instead of 
SSL: 

 From the ‘Microsoft Exchange Management Shell’, type ‘set-
imapsettings -logintype plaintextlogin’ and click Enter. 

 Restart the ‘Microsoft Exchange Information Store’ 

 Restart the ‘Microsoft Exchange IMAP Service’. 

3.5  Installation procedure 

3.5.1  Important notes 

1. Ensure that you are logged on as Administrator or using an account 
with administrative privileges. 

2. Save any pending work and close all open applications on the 
machine. 

3. Check that the machine you are installing GFI MailArchiver on 
meets the system and hardware requirements specified earlier in this 
chapter. 

4. Check the Microsoft Exchange Server role: 

 GFI MailArchiver cannot be installed on the Microsoft Exchange 
Server 2007/2010 Edge Role, since such a server is typically 
deployed on a DMZ using ADAM instead of Active Directory. 

 Ensure to enable IMAP if installing on the Microsoft Exchange 
Server 2007/2010 Client Access Role. 

5. Ensure that Journaling is enabled on Microsoft Exchange Server. 

3.5.2  Installing GFI MailArchiver 

1. Double-click on: 

 mailarchiver6.exe to install GFI MailArchiver on x86 systems 

 mailarchiver6_x64.exe to install GFI MailArchiver on x64 systems 

2. On the Welcome page, click Next. 
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3. Select whether to check for a newer build of GFI MailArchiver on 
the GFI website. Click Next to continue. 

4. Read the license agreement and select I accept the terms in the 
license agreement option. Click Next to continue. 

 
Screenshot 20 - Entering the administrator email address and product license key 

5. Key in the administrator email address and license key. 

NOTE: To evaluate GFI MailArchiver, leave the default ‘evaluation’ 
value. Click Next to continue. 

6. Click Next to continue by installing GFI MailArchiver to the default 
folder. For an alternative location, click Change and select a new 
installation path. 
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Screenshot 21 - Selecting a Website and Virtual Directory 

7. Select the website where you want to install the GFI MailArchiver 
web interface from the Website list. In the Virtual Directory Alias box 
(set to ‘MailArchiver’ by default), key in the name for the GFI 
MailArchiver web interface virtual folder. Click Next to continue. 

8. Click Install to install GFI MailArchiver. 

9. Click Tell me more for detailed information on configuring Microsoft 
Exchange server journaling. Follow the instructions to enable 
Microsoft Exchange Journaling and click Next to continue setup. 

NOTE 1: For detailed instructions on how to enable journaling, refer to 
the Installation pre-requisite: Enable Journaling section starting on 
page 8 of this manual. 

NOTE 2: Next button is disabled until the Tell me more button is 
clicked. 

NOTE 3: If Journaling is already enabled on Microsoft Exchange 
server, select the I do not want... option. This will enable you to 
continue setup without reviewing the instructions on how to enable 
journaling. 

10. Click Finish to close the installation wizard. 

3.6  Post install actions 

3.6.1  Enter your license key 

A valid license key enables you to use GFI MailArchiver without any 
restrictions. 

1. Click Start ► All Programs ► GFI MailArchiver ► GFI 
MailArchiver and key in username and password of an account with 
administrative privileges to access the GFI MailArchiver configuration. 

2. Click GFI MailArchiver ► Configuration ► Licensing node. 
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3. Key in or paste the GFI MailArchiver license key you bought in the 
License key field then click Verify License Key. 

4. Click Save Settings. 

3.6.2  Configure archiving and user exclude options 

By default, GFI MailArchiver archives all emails sent or received by all 
mail users. If all emails need to be archived then no configuration is 
required. To configure which emails to archive and the mailboxes to 
include or exclude for email archiving:  

1. From the GFI MailArchiver management console, select 
Configuration ► Archiving and User Exclude Options. 

2. Under Archiving Options, unselect any emails that you do not want 
to archive (inbound, outbound or internal). 

3. Under User Exclude or Include Options, select Enable Archiving 
Restriction to configure which users to exclude or include in email 
archiving. 

4. Select one of the following options: 

Exclusion list 

 Do NOT archive email at all if ANY of the recipients or senders are 
in the list below 

 Always archive email but users in the list below will not be able to 
view it 

Inclusion list 

 Always archive email if ANY of the recipients or senders are in the 
list below 

 Only archive email if all recipients and senders are in the list below 

NOTE: For licensing purposes, the number of users in the Exclusion 
and Inclusion list are used to count the number of GFI MailArchiver 
licensed users. This is applicable only when the list contains Users 
and not email addresses.  

 When using an Exclusion list, GFI MailArchiver counts the number 
of Active Directory mail-enabled users, less the ones in the 
Exclusion list for licensing purposes. 

 When using an Inclusion list, GFI MailArchiver licenses the 
number of Active Directory mail-enabled users in the Inclusion list 
for licensing purposes. 

 When one or more email addresses are added to the list, GFI 
MailArchiver counts the number of Active Directory mail-enabled 
users for licensing purposes. 

5. Add users to whom the selected restriction shall apply in the list. 

6. Click Save Settings to save archiving and user exclude options. 

3.6.3  Configure the mail servers to archive 

1. From the GFI MailArchiver management console, expand 
Configuration node and click Mail Servers to Archive. 

2. Click Add Mail Server. 

3. Select the type of mail server that you want to configure (local or 
remote) and click Next. 
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4. Select the journaling mailbox from where to archive emails and click 
Next. 

5. Select: 

 ExOLEDB - recommended when GFI MailArchiver is installed on 
the same machine as Microsoft Exchange Server 2000, 2003 or 
2007. 

 IMAP - Select this option when GFI MailArchiver is not installed on 
the same machine as Microsoft Exchange 2000, 2003 or 2007. 
Key in the following: 

o Server - IP address or server name of remote Microsoft 
Exchange server. 

o <Optional> IMAP Port - Automatically populated with the 
default IMAP port value of 143. If you connect IMAP through 
another port number, key it in the IMAP Port box. 

o <Optional> SSL - Choose this option if you are using IMAP 
through SSL. 

o Journal Login and Password - Key in the login name and 
password for the journaling mailbox to access.  

o Mailbox\Folder - Key in the name of the root folder in the 
mailbox, (usually INBOX), or the full path to the public folder 
(for example, Public Folders/JournalFolder), that is being used 
for journaling on the Microsoft Exchange Server. Click Next to 
continue. 

NOTE: Using public folders is not recommended since these 
do not archive all types of reports. 

 Exchange Web Services - Recommended when adding a 
Microsoft Exchange 2007 (SP1) or 2010 mail server. Key in: 

o Journal Login and Password - Key in the login name and 
password for the journaling mailbox to access.  

o Mailbox\Folder - Key in the name of the root folder in the 
mailbox, (usually INBOX), or the full path to the public folder 
(for example, Public Folders/JournalFolder), that is being used 
for journaling on the Microsoft Exchange Server. Click Next to 
continue. 

Click Next to continue setup. 

6. In the Connection test screen, click Next. 

7. Click Finish to finalize setup and Save Settings save new mail 
server to archive. 

3.6.4  Configure Archive Stores 

Archive Stores are the GFI MailArchiver databases where emails are 
archived. On installing GFI MailArchiver, a Firebird database is 
automatically installed. To change the default database: 

1. From the GFI MailArchiver management console, expand the 
Configuration node and click on Archive Stores. 

2. Click Add Archive Store. 

3. In the Archive Store Name field, key in a name for the new archive 
store, and click Next. 
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4. Select the type of archive store to add, depending on the type of 
setup configured in section Installation pre-requisite: Setup database 
on page 24 of this manual: 

 Microsoft SQL server - To use a Microsoft SQL Server database 
where ALL the archive information (including original email binary 
source) will be stored. 

 Microsoft SQL Server database and file system - To use a 
Microsoft SQL server as the backend database and a separate 
location for the binary sources files. 

 GFI MailArchiver database and file system - To use a Firebird 
database as the backend database and a separate location for the 
binary sources files. 

Click Next to continue setup. 

5. Specify the location where to store archive data. Click Next to 
continue setup. 

6. Specify a location where the original emails (binary source) will be 
stored. Also, specify login details in case of a UNC path. Click Next to 
continue setup. 

7. At the verify schema screen click Next. 

8. Specify the location where the search indexes will be stored. Click 
Next to continue setup. 

NOTE: It is highly recommended to always use a different physical 
disk from where the Firebird or SQL server data is stored as the index 
location. 

9. Click Finish to finalize setup and Save Settings save new archive 
store. 

3.6.5  Configure access control 

By default, an Active Directory user can browse and search only 
through his/her emails. Access control enables configurations where 
specific users or groups can access other user’s emails. 

1. From the GFI MailArchiver management console, expand 
Configuration node and click Access Control. 

2. Under Full Access Group, select any Active Directory group to 
grant full access permissions to on all archived emails. 

3. Under Group Managers, configure any group managers that 
should have access to the archived emails of the users part of a 
particular AD group. Click Add Manager assign group managers. 

4. Under User Access Control, configure any users that should have 
access to the archived emails of other users. Click Add User to 
finalize user setup. 

5. Click Save Settings to finalize access control setup. 

3.6.6  Configure search indexes 

Search indexes enable the timely retrieval of archived emails. 

1. From the GFI MailArchiver management console, expand 
Configuration node and click on Search Index Management. 

2. Select an index frequency: 
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 Index new archived emails immediately - Emails are indexed as 
soon as these are received by GFI MailArchiver. This is the default 
value. 

 Index new archived emails every - Emails are indexed on a 
specified periodical timed schedule (e.g. every half hour, every 
hour, etc) 

 Index new archived emails every day at: - Emails are indexed 
on a daily basis at a specified time. (e.g. daily at 00:30 am) 

NOTE: Frequent email indexing requires more hardware resources, 
such as hard disk speed. 

3.6.7  Set up retention policies 

Retention policies enable you to configure how long specific emails 
are kept in the archive store. 

1. From the GFI MailArchiver management console, expand 
Configuration node and click Retention Policies. 

2. Click on Add Retention Policy. 

3. Key in a name of the new policy and click Next. 

4. Specify any subject keywords and click Next. 

5. Specify any body keywords and click Next. 

6. Specify any email senders and click Next. 

7. Specify any email recipients and click Next. 

8. Specify whether emails matching the criteria that you set up should 
be deleted immediately or after a number of days and click Next. 

9. Click Finish to finalize retention policy setup and Save settings to 
save settings. 

3.6.8  Configuring general settings 

The General Settings configuration page enables you to specify the 
administrator email address, the SMTP server and port number details 
used by GFI MailArchiver to: 

 Send administrative notification emails  

 Restore emails through OneClick Restore. 

To configure the general settings: 

1. Click GFI MailArchiver ► Configuration ► General Settings 
node.  
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Screenshot 22 - Configuring general settings 

2. Set up:  

 Administrator Email Address - Specify the administrator email 
address to which notification messages are sent. 

 SMTP Server - Key in the SMTP server name to use to send 
emails through. 

 Port number - Key in the port number over which email 
communications are sent to the SMTP server. 

 Use SSL - Select this option to secure communication to SMTP 
server. 

 This SMTP server uses authentication - Select this option if your 
SMTP server requires authentication and key in the login 
credentials. 

3. Click Save Settings. 

3.6.9  Configuring mailbox folder structure retrieval 

User mailbox structure retrieval enables users to view the folder 
structure set up for each individual user set up in Microsoft Exchange. 

When configured, the folder structure of the users’ mailbox is 
replicated in the GFI MailArchiver archive stores and can be viewed in 
the: 

 Mailboxes in GFI MailArchiver user interface 

 Folders created by GFI MailArchiver Outlook Connector. 
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How does mailbox folder structure retrieval work? 

 
Figure 2 - User mailbox structure retrieval 

 Retrieve mailbox folder structure for all users. 

 Save retrieved mailbox folder structure within the GFI MailArchiver 
archive store.  

 GFI MailArchiver retrieves the mailbox folder structure from archive 
store 

 GFI MailArchiver displays email conversations within the retrieved 
archive stores to users. 

Important Notes 

1. If emails are manually moved from Sent Items folder to another 
folder, this change will not be replicated in GFI MailArchiver Archive 
Stores if Cached Exchange Mode is enabled on the users’ Microsoft 
Outlook account settings. For more information about Cached 
Exchange Mode refer to the General issues section in 
Troubleshooting. 

Step 1: Create a dedicated user 

A dedicated user is required for User mailbox structure retrieval. The 
procedure how to create a user in Active Directory depends on the 
operating system of the domain controller: 
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 Microsoft Windows Server 2000/2003 

 Microsoft Windows Server 2008 

NOTE 1: In a Microsoft Exchange 2010 environment, skip to Step 2: 
Grant user access to all users’ mailboxes. 

NOTE 2: The dedicated user does not require a mailbox to be 
attached. 

Microsoft Windows Server 2000/2003 

1. Click Start ► Settings ► Control Panel ► Administrative Tools 
► Active Directory Users and Computers. 

2. Expand <Domain Name> ► Users node and right click Users ► 
New ► User. 

3. Key in ‘First name’, ‘Last name’, ‘Full name’ and ‘User logon name’ 
and click Next. 

4. Key in ‘Password’ and ‘Confirm password’ values, unselect User 
must change password at next logon option, select User cannot 
change password and select Password never expires. Click Next 
to continue setup. 

5. Unselect Create an Exchange mailbox option and click Next. 

6. Review new user details and click Finish to create new user. 

Proceed to Step 2: Grant user access to all users’ mailboxes. 

Microsoft Windows Server 2008 

1. Click Start ► Run and key in cmd, and OK. 

2. Key in:  

dsadd user <UserDN>  -pwd <password> -disabled no 

Where: 
Parameter Description 

<UserDN> Specifies the distinguished name of the user object to 
be added. 

-pwd Sets <password> value. 

<Password> Specifies the password to be used for the user 
account. If this parameter is set to *, you are 
prompted for a user password. 

 Example:  

dsadd user CN=masynch,CN=Users,DC=master-

domain,DC=Com -pwd Password1 -disabled no 

Proceed to Step 2: Grant user access to all users’ mailboxes. 

Step 2: Grant user access to all users’ mailboxes 

From the Microsoft Exchange Server, grant the user created in step 1 above 
access to all users’ mailboxes. The procedure to grant access depends on 
the version of Microsoft Exchange Server: 

 Microsoft Exchange 2000/2003 

 Microsoft Exchange 2007 (not SP1/SP2/SP3) 

 Microsoft Exchange 2007 SP1/SP2/SP3 

 Microsoft Exchange 2010 
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Microsoft Exchange 2000/2003 

1. Login to the Microsoft Exchange Server 2000/2003 machine and 
from the Microsoft Exchange System Manager, expand Server 
node from the appropriate administrative group. Right click the server 
and click Properties. 

2. Select Security tab. 

3. If the user that is allowed to access all user mailboxes is added in 
Group or user names box, then proceed to Step 3: Assign user logon 
rights to the GFI MailArchiver machine. If the user that is allowed to 
access all user mailboxes is NOT added in Group or user names 
box, click Add… to add the user. 

 
Screenshot 23 - Allow full control to user who has full control on all user mailboxes 

4. In the permissions list, click Allow next to Full Control to grant full 
control permissions to the user just created. 

Proceed to Step 3: Assign user logon rights to the GFI MailArchiver 
machine. 

Microsoft Exchange 2007 (not SP1/SP2/SP3) 

1. Open the Exchange Management Shell. 

2. Run the following Windows PowerShell commandlet 

Add-ADPermission -identity “Mailbox Store” -User 

“Trusted User” -AccessRights GenericAll 
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 Example: Add-ADPermission -Identity “Mailbox 

Database” -User “master-domain\masynch” -

AccessRights GenericAll 

Repeat the procedure described above for each mailbox store 
database required. 

Proceed to Step 3: Assign user logon rights to the GFI MailArchiver 
machine. 

Microsoft Exchange 2007 SP1/SP2/SP3 

1. Open the Exchange Management Shell. 

2. Run the following Windows PowerShell commandlet: 

foreach ($exchangeServer in Get-ExchangeServer)  

{  

if ($exchangeServer.ServerRole -match 

'ClientAccess')  

{  

Add-ADPermission -Identity 

$exchangeServer.DistinguishedName -User 

'domain\user' -ExtendedRights ms-Exch-EPI-

Impersonation   

} 

} 

 Example:  

foreach ($exchangeServer in Get-ExchangeServer)  

{  

if ($exchangeServer.ServerRole -match 

'ClientAccess')  

{ 

Add-ADPermission -Identity 

$exchangeServer.DistinguishedName   -User 

'master-domain\masynch' -ExtendedRights ms-

Exch-EPI-Impersonation   

} 

} 

Repeat the procedure described above for each mailbox store 
database required. 

Proceed to Step 3: Assign user logon rights to the GFI MailArchiver 
machine. 

Microsoft Exchange 2010 

1. Launch the Exchange Management Shell. 

2. Key in: 

New-mailbox -name “name” -userprincipalname 

name@domain.com -organizationalunit users 

 Example:  
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New-mailbox -name “masynch” -userprincipalname 

masynch@masterdomain.com -organizationalunit 

users 

3. Key in a password and hit Enter to create the new user. 

4. Run the following PowerShell commandlet: 

New-ManagementScope -name "MAUMPolling" -

recipientrestrictionfilter {recipienttype -eq 

"UserMailbox"} 

5. Run the following PowerShell commandlet: 

New-ManagementRoleAssignment -name "MAUMPollingRA" 

-role:applicationimpersonation -user 

"masynch@domain.com" -customrecipientwritescope 

"MAUMpolling" 

 Example:  

New-ManagementRoleAssignment -name 

"MAUMPollingRA" -role:applicationimpersonation -

user "masynch@mydomain.com" -

customrecipientwritescope "MAUMpolling" 

Repeat the procedure described above for each mailbox store 
database required. 

Proceed to Step 3: Assign user logon rights to the GFI MailArchiver 
machine. 

Step 3: Assign user logon rights to the GFI MailArchiver machine 

The user dedicated to the User mailbox structure retrieval feature must have 
logon rights on the GFI MailArchiver machine. This procedure depends on 
which machine GFI MailArchiver is installed on: 

 GFI MailArchiver installed on a domain member server 

 GFI MailArchiver installed on the domain controller 

GFI MailArchiver installed on a domain member server 

1. From the domain controller machine, navigate to Control Panel ► 
Administrative Tools ► Active Directory Users and Computers. 

2. Right-click the user dedicated to the User mailbox structure retrieval 
and click Properties. 

3. Select Account tab and click Log On To…. 

4. Select either All computers to allow log in to all domain member 
computers or select The following computers and add the GFI 
MailArchiver server name to allow login only to the GFI MailArchiver 
machine. 

5. Click OK to apply changes. 

6. Load command prompt and key in gpupdate to refresh the local 
and Active Directory-based Group Policy settings. 

Proceed to Step 4: Configure Mailbox folder structure retrieval in GFI 
MailArchiver. 

GFI MailArchiver installed on the domain controller 

Windows Server 2003 
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1. Navigate to Control Panel ► Administrative Tools and select 
Domain Controller Security Policy. 

2. Expand Local Policies and click User Rights Assignment 

3. From the right pane, double click Allow log on locally 

4. Click Add User or Group and key in the user configured in the GFI 
MailArchiver Mailbox Synchronization configuration. 

5. Load command prompt and key in gpupdate to refresh the local 
and Active Directory-based Group Policy settings. 

Proceed to Step 4: Configure Mailbox folder structure retrieval in GFI 
MailArchiver. 

Windows Server 2008 

1. Navigate to Start ► Run and type gpme.msc. 

2. In Domains/OUs tab, double click Domain Controllers and launch 
the Default Domain Controllers Policy. 

3. Navigate to Default Domain Controllers Policy ► Computer 
Configuration ► Policies ► Windows Settings ► Security 
Settings ► Local Policies ► User Rights Assignment. 

4. From the right pane, double click Allow log on locally. 

5. Click Add User or Group and key in the user dedicated to User 
folder structure retrieval. 

6. Load command prompt and key in gpupdate to refresh the local 
and Active Directory-based Group Policy settings. 

Proceed to Step 4: Configure Mailbox folder structure retrieval in GFI 
MailArchiver. 

Step 4: Configure Mailbox folder structure retrieval in GFI 
MailArchiver 

1. From GFI MailArchiver, navigate to GFI MailArchiver ► 
Configuration ► Mailbox Folder Structure Retrieval. 

2. Select Enable GFI MailArchiver to copy the mailbox folder 
structure checkbox. 

3. Select the connection method to Microsoft Exchange: 

 Traditional Message Application Programming Interface 
(MAPI): Use this option if you are using Microsoft Exchange 
Server 2000/2003/2007.  

 Exchange Web Services: Use this option if you are using 
Microsoft Exchange 2007 SP1 and later only. 

4. Key in the Login Name and Password for the user dedicated to 
Mailbox folder structure retrieval.  

NOTE: Specify login name in domain\username format. 

5. Click Test access to mailboxes button to text access to 
mailboxes. If test fails, check credentials and retest. 

6. <Optional> Click Add New Policy to create a policy that excludes 
specific folders from being replicated. 

 Key in policy name and click Next. 

 Add folders to exclude and click Next. 
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 To apply new policy to selected users only, select Apply for 
selected users only option and key in the users to which this 
folder applies. 

 Click Next and Finish to finalize the new policy setup.  

7. Click Save Settings to complete setup. 

3.7  Test your setup 

Test your setup to ensure that emails are archived successfully. 

1. From an external account (e.g. Webmail, Hotmail, Gmail, etc) 
create a new email and send it to a valid email address which mailbox 
contents are being archived. 

2. From the GFI MailArchiver management console, expand 
Conversations node and click Browse. 

3.  From the List conversations from option select the user for whom 
to browse conversations. 

 
Screenshot 24 - Email sent from webmail to Microsoft Exchange Server email account 
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Screenshot 25 - Email archived by GFI MailArchiver 

4. Review the conversations to ensure that emails sent are displayed 
in GFI MailArchiver. 

 Example: 

o Send an email from a webmail account to an email account 
which is being archived (e.g. john.doe@companydomain.com). 

o Select Conversations ► Browse and select the email 
account to review (john.doe@companydomain.com).  

o Review the conversation threads listed and locate the email 
sent from webmail.  

In case that emails are not being archived by GFI MailArchiver: 

 Ensure that your email infrastructure is working correctly by 
checking that the email is received by your Microsoft Exchange 
server and that it goes through the recipient mailbox. 

 Ensure that all the installation pre-requisites starting on page 8 in 
this manual are completed 

 Ensure that all the installation and post installation actions in this 
manual are completed correctly. 

 Refer to the Administration and configuration guide available from: 

http://www.gfi.com/mar/mar6acmanual.zip 

 

http://www.gfi.com/mar/mar6acmanual.zip
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4.  Upgrades 

4.1  Upgrade procedure 

4.1.1  Important notes 

1. Ensure that you are logged on as Administrator or using an account 
with administrative privileges. 

2. Before starting installation, save any other pending software and 
close all open applications on the machine. 

3. Check that the machine you are installing GFI MailArchiver on 
meets the system and hardware requirements specified earlier in this 
chapter. 

4. Ensure that Journaling is enabled on Microsoft Exchange Server. 
Refer to the Installation pre-requisite: Enable Journaling section 
starting on page 8 in this manual for information on how to check if 
journaling is enabled. 

4.1.2  Upgrading GFI MailArchiver 

1. Double-click on: 

 mailarchiver6.exe to install GFI MailArchiver on x86 systems. 

 mailarchiver6_x64.exe to install GFI MailArchiver on x64 
systems. 

2. On the Welcome page, click Next. 

3. Select whether to check for a newer build of GFI MailArchiver on 
the GFI Website. Click Next to continue. 

4. Read the license agreement and select I accept the terms in the 
license agreement option. Click Next to continue. 

5. Select the language used by the GFI MailArchiver language 
analyzer to accurately index non-Roman character languages. Click 
Next to continue. 
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Screenshot 26 - Entering the administrator email address and product license key 

6. Key in the administrator email address (used for notification 
messages) and license key. 

NOTE: To evaluate GFI MailArchiver, leave the default ‘evaluation’ 
value. Click Next to continue. 

7. Click Next to continue by installing GFI MailArchiver to the default 
folder. For an alternative location, click Change and select a new 
installation path. 

 
Screenshot 27 - Selecting a Website and Virtual Directory 

8. Select the website where you want to install the GFI MailArchiver 
web interface from the Website list. In the Virtual Directory Alias box 
(set to ‘MailArchiver’ by default), key in the name for the GFI 
MailArchiver web interface virtual folder. Click Next to continue. 
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9. Click Install to install GFI MailArchiver. 

10. Click Upgrade to upgrade your database schema to the new GFI 
MailArchiver schema and click Next to continue setup. 

NOTE 1: Next button is disabled until the Tell me more button is 
clicked. 

NOTE 2: To continue setup without updating your database schema, 
select the I do not want to upgrade the schema now option and 
click Next. 

11. Click Finish to close the installation wizard. 

4.2  Post upgrade actions 

4.2.1  Check licensing 

A valid license key enables you to use GFI MailArchiver without any 
restrictions. If upgrading: 

 From the same version but an older build (e.g. from version 6.0 
to version 6.1), check license key. For more information on 
obtaining a new license key, refer to: 

http://www.gfi.com/products/gfi-mailarchiver/pricing 

 From a previous version of GFI MailArchiver (e.g. version 5 to 
version 6): follow the steps below to enter fully purchased license 
key for current version. 

1. Click Start ► All Programs ► GFI MailArchiver ► GFI 
MailArchiver and key in username and password of an account with 
administrative privileges to access the GFI MailArchiver configuration. 

2. Click GFI MailArchiver ► Configuration ► Licensing node. 

3. Key in or paste the GFI MailArchiver license key you bought in the 
License key field then click Verify License Key. 

4. Click Save Settings. 

http://www.gfi.com/products/gfi-mailarchiver/pricing




 

GFI MailArchiver for Exchange - Getting Started Guide Deploy Outlook connector  49 

5.  Deploy Outlook connector 

Use the GFI MailArchiver outlook connector to access your email 
archives from within your Microsoft Outlook software. This connector 
can be installed via Active Directory Group Policy Objects (GPO) or 
via manual install. 

5.1  System requirements 

5.1.1  Software 

Supported Microsoft Outlook Versions 

 Microsoft Outlook 2003 (including Service Packs 1, 2, 3 or 4) 

 Microsoft Outlook 2007 (including Service Packs 1 or 2) 

 Microsoft Outlook 2010 (x86 and x64 versions) 

Supported operating systems 

GFI MailArchiver can be installed on: 

 Microsoft Windows 7 

 Microsoft Windows Vista 

 Microsoft Windows XP 

 Microsoft Windows Server 2008 

 Microsoft Windows Server 2003 

 Microsoft Windows Server 2000 

NOTE 1: The machines where GFI MailArchiver Outlook Connector is 
deployed must be able to connect to the GFI MailArchiver server. 

NOTE 2: GFI MailArchiver Outlook Connector cannot be installed on 
the Microsoft Exchange server. 

NOTE 3: When using a web filtering tool, this must be configured to 
allow all HTTP requests between GFI MailArchiver server and GFI 
MailArchiver Outlook Connector. Ensure that the GFI MailArchiver 
server’s IP address, NETBIOS name and DNS name are not blocked 
by the web filter. For more information, refer to: 

http://kbase.gfi.com/showarticle.asp?id=KBID003387. 

Other required components 

 Microsoft Internet Explorer 5 or later. 

 HTTP port 80 (or HTTPS default port 443 for secure connections) - 
used by GFI MailArchiver Outlook Connector to connect with GFI 
MailArchiver. 

5.1.2  Hardware 

Processor 

 1GHz processor or more. 

http://kbase.gfi.com/showarticle.asp?id=KBID003387
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Memory 

 Minimum: 512MB RAM 

 Recommended: 2GB RAM 

Physical Storage 

 20MB physical disk space required for GFI MailArchiver Outlook 
Connector installation. More space is required to store email 
headers and emails for offline access. 

5.2  Installing via GPO  

5.2.1  Windows Server 2003 

NOTE: Make sure that when deploying the 32-bit version of the GFI 
MailArchiver Outlook Connector, the domain policy used contains only 
computers with Microsoft Outlook 2010 32-bit version installed.  

Also ensure to use a domain policy that applies only to computers 
where Microsoft Outlook 2010 64-bit version is installed when 
deploying GFI MailArchiver 2010 64-bit edition. 

1. Navigate to <Program Files\GFI\MailArchiver\Outlook> and copy: 

 MAROC_32bitOutlook.msi (Installer for Microsoft Outlook 
2010 32-bit computers only)  

 MAROC_64bitOutlook.msi (Installer for Microsoft Outlook 
2010 64-bit computers only) 

to a share accessible by all domains. 

2. From command prompt, key in ‘mmc.exe’ and click Enter to launch 
the Microsoft Management Console. 

3. Click File ► Add/Remove Snap-in… and click Add... 

4. Select Group Policy Object Editor snap-in and click Add. 

5. Click Browse… and select the domain policy to edit. 

6. Select the domain policy and click OK. 

7. Click Finish to close ‘Select Group Policy Object’ dialog. Click 
Close to close ‘Add standalone Snap-in’ dialog and click OK to close 
‘Add/Remove Snap-in’ dialog; to return to the Microsoft Management 
Console. 

8. Navigate to Console Root ► <domain policy> ► User 
Configuration, right-click Administrative Templates, and select 
Add/Remove Templates…. 

9. Click Add…, browse for the file gfiapps.adm located in: 
<Program Files\GFI\MailArchiver\Outlook> and click Open. 

10. Click Close to return to the Microsoft Management Console. 

11. Expand Console Root ► <domain policy> ► User 
Configuration ► Administrative Templates ► GFI Applications. 
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Screenshot 28 - Defining the server URL of GFI MailArchiver in GPO 

12. From the right pane, double click GFI MailArchiver Server 
Location policy and select Enabled. In the Server URL text box enter 
the URL where user machines can access GFI MailArchiver in the 
form http://<hostname>/<GFI MailArchiver virtual 

folder name> 

For example:  

http://win2k3entsvr.master-domain.com/MailArchiver 

13. <Optional> Click Next Setting and configure the following 
settings. For each option select Not Configured to use the default 
value or click Enable to specify a custom value. 

 GFI MailArchiver Outlook Connector Data Path Root - specify a 
different root location where store configurations and local emails 
are stored on client machines. For example type 
„%MyDocuments%‟ to store in the My Documents folder of the 
logged on user. 

 GFI MailArchiver Outlook Connector days span - specify the 
number of days for which emails are synchronized. Only emails 
received within this time span are accessible through GFI 
MailArchiver Outlook Connector. 

 GFI MailArchiver Outlook Connector download batch size - 
Specify how many emails can be downloaded during one 
synchronization session. 

 GFI MailArchiver Outlook Connector connection timeout - 
Specify the timeout period in milliseconds for accessing data from 
the GFI MailArchiver server. 
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 GFI MailArchiver Outlook Connector maximum offline days - 
Specify the maximum number of days which a user can set for 
emails offline access. 

 GFI MailArchiver Outlook Connector offline support - Enable 
or disable offline support. If offline support is enabled, specify the 
number of days to support offline access. If this setting is enabled: 

o Users are not allowed to modify offline access 

o GFI MailArchiver Outlook Connector maximum offline days 
setting is ignored. 

14. Click OK when all settings are configured. 

15. Select Console Root ► <domain policy> ► Computer 
Configuration ► Software Settings. 

16. Right click Software installation and select New ► Package… 

17. In the Open dialog, locate the share where msi file is saved. 

NOTE: When selecting the location of the msi file ensure that this is 
done through ‘My network locations’ so that the share name in GFI 
MailArchiver includes the full network share location rather than the 
local path. 

18. Choose the deployment option - select Assigned and OK. 

19. GFI MailArchiver Outlook Connector will be installed the next time 
each client machine is started. 

To check installation, from Microsoft Outlook, check that a new folder 
called GFI MailArchiver Mailbox is created. 

For information on how to use the GFI MailArchiver Outlook 
Connector, refer to the GFI MailArchiver Outlook connector manual 
available from:  

http://www.gfi.com/mar/mar6ocmanual.zip 

5.2.2  Windows Server 2008 

NOTE: Make sure that when deploying the 32-bit version of the GFI 
MailArchiver Outlook Connector, the domain policy used contains only 
computers with Microsoft Outlook 2010 32-bit version installed.  

Also ensure to use a domain policy that applies only to computers 
where Microsoft Outlook 2010 64-bit version is installed when 
deploying GFI MailArchiver 2010 64-bit edition. 

1. Navigate to <Program Files\GFI\MailArchiver\Outlook> and copy: 

 MAROC_32bitOutlook.msi (Installer for Microsoft Outlook 
2010 32-bit computers only)  

 MAROC_64bitOutlook.msi (Installer for Microsoft Outlook 
2010 64-bit computers only) 

to a share accessible by all domains. 

2. From command prompt, key in ‘mmc.exe’ and click Enter to launch 
the Microsoft Management Console. 

3. Click File ► Add/Remove Snap-in… and click Add... 

4. Select Group Policy Management Editor snap-in and click Add. 

5. Click Browse… and select the domain policy to edit. 

6. Select the domain policy and click OK. 

7. Click Finish to close ‘Select Group Policy Object’ dialog. Click 
Close to close ‘Add standalone Snap-in’ dialog and click OK to close 

http://www.gfi.com/mar/mar6ocmanual.zip
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‘Add/Remove Snap-in’ dialog; to return to the Microsoft Management 
Console. 

8. Navigate to Console Root ► <domain policy> ► User 
Configuration ► Policies, right-click Administrative Templates, 
and select Add/Remove Templates…. 

9. Click Add…, browse for the file gfiapps.adm located in: 
<Program Files\GFI\MailArchiver\Outlook> and click Open. 

10. Click Close to return to the Microsoft Management Console. 

11. Expand Console Root ► <domain policy> ► User 
Configuration ► Policies ► Administrative Templates ► GFI 
Applications. 

 
Screenshot 29 - Defining the server URL of GFI MailArchiver in GPO 

12. From the right pane, double click GFI MailArchiver Server 
Location policy and select Enabled. In the Server URL text box enter 
the URL where user machines can access GFI MailArchiver in the 
form http://<hostname>/<GFI MailArchiver virtual 

folder name> 

For example:  

http://win2k3entsvr.master-domain.com/MailArchiver 

13. <Optional> Click Next Setting and configure the following 
settings. For each option select Not Configured to use the default 
value or click Enable to specify a custom value. 

 GFI MailArchiver Outlook Connector Data Path Root - specify a 
different root location where store configurations and local emails 
are stored on client machines. For example type 
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„%MyDocuments%‟ to store in the My Documents folder of the 
logged on user. 

 GFI MailArchiver Outlook Connector days span - specify the 
number of days for which emails are synchronized. Only emails 
received within this time span are accessible through GFI 
MailArchiver Outlook Connector. 

 GFI MailArchiver Outlook Connector download batch size - 
Specify how many emails can be downloaded during one 
synchronization session. 

 GFI MailArchiver Outlook Connector connection timeout - 
Specify the timeout period in milliseconds for accessing data from 
the GFI MailArchiver server. 

 GFI MailArchiver Outlook Connector maximum offline days - 
Specify the maximum number of days which a user can set for 
emails offline access. 

 GFI MailArchiver Outlook Connector offline support - Enable 
or disable offline support. If offline support is enabled, specify the 
number of days to support offline access. If this setting is enabled: 

o Users are not allowed to modify offline access 

o GFI MailArchiver Outlook Connector maximum offline days 
setting is ignored. 

14. Click OK when all settings are configured. 

15. Select Console Root ► <domain policy> ► Computer 
Configuration ► Policies ► Software Settings. 

16. Right click Software installation and select New ► Package… 

17. In the Open dialog, locate the share where msi file is saved. 

NOTE: When selecting the location of the msi file ensure that this is 
done through ‘My network locations’ so that the share name in GFI 
MailArchiver includes the full network share location rather than the 
local path. 

18. Choose the deployment option - select Assigned and OK. 

19. GFI MailArchiver Outlook Connector will be installed the next time 
each client machine is started. 

To check installation, from Microsoft Outlook, check that a new folder 
called GFI MailArchiver Mailbox is created. 

For information on how to use the GFI MailArchiver Outlook 
Connector, refer to the GFI MailArchiver Outlook connector manual 
available from:  

http://www.gfi.com/mar/mar6ocmanual.zip 

5.3  Installing without GPO - Manual install 

1. Copy: 

 MAROC_32bitOutlook.exe (Installer for Microsoft Outlook 
2010 32-bit computers only)  

 MAROC_64bitOutlook.exe (Installer for Microsoft Outlook 
2010 64-bit computers only) 

located in <Program Files\GFI\MailArchiver\Outlook> to the client 
machines on which you would like to install the GFI MailArchiver 
Outlook Connector. 

http://www.gfi.com/mar/mar6ocmanual.zip
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2. Double click on the file and follow the wizard to install. 

To check installation, from Microsoft Outlook, check that a new folder 
called GFI MailArchiver Mailbox is created. 

3. <Optional>: Add the Outlook connector administrator template that 
will set up Outlook connector. 

 From command prompt, type mmc.exe and click Enter. 

 Click File ► Add/Remove Snap-in… and click Add... 

 Select ‘Group Policy Object Editor’ snap-in and click Add… 

 Click Browse… and select the domain policy to edit. 

 Select the domain policy and click OK.  

NOTE: Make sure that when deploying the 32-bit version of the 
GFI MailArchiver Outlook Connector, the domain policy used 
contains only computers with Microsoft Outlook 2010 32-bit 
version installed.  

Also ensure to use a domain policy that applies only to computers 
where Microsoft Outlook 2010 64-bit version is installed when 
deploying GFI MailArchiver 2010 64-bit edition. 

 Click Finish to close ‘Select Group Policy Object’ dialog. Click 
Close to close ‘Add standalone Snap-in’ dialog and click OK to 
close ‘Add/Remove Snap-in’ dialog. 

 Select Console Root ► User Configuration, right click 
Administrative Templates and select Add/Remove Templates… 

 Click Add… and browse for the file gfiapps.adm located in: 
<\<folder name>\GFI\MailArchiver\Outlook> 

 Click Open. 
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6.  Role-based Installations 

6.1  Introduction 

Role-based Deployment allows for scalability of GFI MailArchiver in 
large IT infrastructures dealing with heavy email traffic. This is 
achieved through the deployment of multiple GFI MailArchiver 
instances on separate servers. Each instance is configured to fulfill 
diverse roles, to balance workload and collectively help for the smooth 
running of the email archiving process. 

The following roles can currently be assigned to GFI MailArchiver 
instances: 

 Central Configuration Service 

 Data Collection 

 Storage 

 Search and Indexing 

 User Interface and Administration 

 Data Import Service 
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6.2  How role-based deployment works 

 
Figure 3 - How Role-based Deployment works 

The GFI MailArchiver role-based deployment process in a distributed 
environment involves the following steps: 

1. Establish the number of GFI MailArchiver instances required and 
the role to assign to each instance. 

2. Install GFI MailArchiver on each server that will be participating in 
the deployment. This is a normal installation as described in the 
previous sections in this manual. 

3. Execute the Deployment Manager Wizard on each GFI MailArchiver 
instance. 

4. Store each server’s deployment configuration file for future 
reference. This file may be required when updating to newer GFI 
MailArchiver builds or when the administrator needs to reconfigure the 
deployment roles. 

5. Configure GFI MailArchiver from the server with the User Interface 
and Administration role. 

NOTE 1: GFI MailArchiver instances communicate with each other 
over the network using the .NET Remoting protocol. 

NOTE 2: A GFI MailArchiver instance can be assigned more than one 
role; the following roles can be assigned to more than one GFI 
MailArchiver instance: 

 Data Collection 

 User Interface and Administration 
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 Data Import Service 

Though there may be a number of GFI MailArchiver instances 
distributed over the network, this fact is transparent to the 
administrator when it comes to configuring GFI MailArchiver, since 
configuration is centralized. Once the deployment process is 
complete, the administrator does not have to configure individual 
servers but can carry out all configuration through the GFI 
MailArchiver management console. In a distributed deployment, the 
GFI MailArchiver management console is accessible from the 
server(s) assigned the User Interface and Administration role. 

6.2.1  System requirements 

For the GFI MailArchiver Role-based deployment, you need: 

 Hardware and software specifications as described in the 
‘Installing GFI MailArchiver’ chapter. 

NOTE 1: Role-based deployment is not supported on Windows 
2000 server. 

NOTE 2: For a Role-based deployment only MS SQL Server 
based Archive Stores are supported. 

NOTE 3: If you are using a Microsoft SQL Server and NTFS file 
system archive store, make sure that the archived email binary 
source path is specified in UNC format. 

 GFI MailArchiver services running under Active Directory 
credentials allowing communication over the network. 

6.3  Installing GFI MailArchiver in a role-based environment 

You assign roles to GFI MailArchiver instances by using the 
Deployment Manager Wizard, which simplifies and streamlines the 
process. 

Installing GFI MailArchiver 

Install GFI MailArchiver on each instance where a role will be 
deployed. Follow the instructions listed in Installation procedure 
section starting on page 29 of this manual. 

Executing the Deployment Manager Wizard on each instance 

You need to execute the Deployment Manager Wizard on each GFI 
MailArchiver instance according to the role(s) it will be assigned, in the 
following order: 

1. Central Configuration Service 

2. Storage 

3. Search and Indexing 

4. Data Collection (more than one allowed) 

5. User Interface and Administration (more than one allowed) 

6. Data Import Service (more than one allowed) 

7. User Mailbox Synchronization 

That is, you should first execute the wizard for the GFI MailArchiver 
instance which will be assigned the Central Configuration Service role, 
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then execute it for the GFI MailArchiver instance with the Storage role, 
and so on. 

Launching the Deployment Manager Wizard 

To launch the Deployment Manager Wizard: 

1. From Command Prompt, navigate to: 

<Program Files Directory>\GFI\MailArchiver\DM\ 

2. Key in deploymentmanager.exe and press Enter. 

Using the Deployment Manager Wizard 

1. After launching the Deployment Manager Wizard you are presented 
with the welcome dialog. Click Next to continue. 

 
Screenshot 30 - Selecting roles 

2. Specify which role(s) will be assigned to the GFI MailArchiver 
instance on this server and click Next. 

NOTE: Move the mouse pointer over any role listed in the dialog to 
view the relevant description for that role. 

3. Based on the roles selected in the previous stage, you will be asked 
to configure some parameters. For information on how to configure 
roles refer to the next sections. Click Next to continue. 
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Screenshot 31 - Specify Active Directory credentials 

4. Specify the Active Directory credentials under which to run GFI 
MailArchiver services and click Next. 

NOTE 1: GFI MailArchiver services must run under an Active 
Directory user account. 

NOTE 2: Specify an account that has read/write access privileges on 
the Microsoft Exchange configuration. 

 
Screenshot 32 - Apply all configuration settings specified 

5. Click Next to initiate the process and apply all specified parameters. 



 

62  Role-based Installations GFI MailArchiver for Exchange - Getting Started Guide 

NOTE: During this process all GFI MailArchiver services need to be 
stopped and re-started. This occurs automatically and may take 
minutes to complete. 

6. Click Finish to finalize your settings and close the Deployment 
Manager Wizard. 

Assigning the Central Configuration Service Role 

 
Screenshot 33 - Assigning the Central Configuration Service role 

To assign the ‘Central Configuration Service Role’ select the 
appropriate option from the list of roles in the ‘Server Role Selection’ 
dialog. 

The server assigned this role maintains the central configuration 
database of the GFI MailArchiver deployment and hosts 
miscellaneous services like email restore and licensing. You can only 
assign the ‘Central Configuration Service Role’ to one server in the 
deployment. 
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Assigning the Data Collection Role 

 
Screenshot 34 - Assigning the Data Collection role 

To assign the ‘Data Collection Role’ select the appropriate option from 
the list of roles in the ‘Server Role Selection’ dialog. 

The server assigned this role collects emails, to be archived, from 
Microsoft Exchange locations. 

To achieve maximum performance, assign the ‘Data Collection Role’ 
to a GFI MailArchiver instance residing directly on the Microsoft 
Exchange server. 

You can assign this role to multiple servers in the deployment. 
However, ensure that the ‘server tagging’ option is enabled when 
assigning the ‘User Interface and Administration Role’. 
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Assigning the Storage role 

 
Screenshot 35 - Assigning the Storage role 

To assign the ‘Storage Role’ select the appropriate option from the list 
of roles in the ‘Server Role Selection’ dialog. The server assigned this 
role provides email storage and retrieval services. 

You can only assign the ‘Storage Role’ to one server in the 
deployment. 
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Assigning the Search and Indexing Role 

 
Screenshot 36 - Assigning the Search and Indexing role 

To assign the ‘Search and Indexing Role’ select the appropriate option 
from the list of roles in the ‘Server Role Selection’ dialog. 

The server assigned this role provides email search and indexing 
services. GFI MailArchiver creates search indexes for each archive 
store you configure. Each search index automatically indexes new 
email content archived in the corresponding archive store, to keep the 
search index updated and enable users to perform precise and fast 
searches. 

You can only assign the ‘Search and Indexing Role’ to one server in 
the deployment. 
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Screenshot 37 - Specify the word breaker for the Search and Indexing role 

You will be prompted to specify the word breaker to use. Word 
breakers for each language enable the resulting terms to be more 
accurate for that language. If no word breaker is available for a 
particular language, the neutral word breaker is used. With the neutral 
word breaker, words are broken at neutral characters such as spaces 
and punctuation marks. 

Select the indexing option available if you also want to index email 
message attachments. 
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Assigning the User Interface and Administration Role 

 
Screenshot 38 - Assigning the User Interface and Administration role 

To assign the ‘User Interface and Administration Role’ select the 
appropriate option from the list of roles in the ‘Server Role Selection’ 
dialog. 

The server assigned this role enables users to browse/search their 
archives and administrators to configure GFI MailArchiver through the 
management console. 

You can assign the ‘User Interface and Administration Role’ to 
multiple servers in the deployment. 
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Screenshot 39 - Specify User Interface and Administration role settings 

You will be prompted to specify the authentication method to use 
(Windows or Forms) to log in to the GFI MailArchiver management 
console. 

If more than one server is assigned the Data Collection role, select the 
Enable server tagging in the Data Sources configuration option. 
Server tagging allows multiple GFI MailArchiver instances running the 
Data Collection role to process different mailboxes without interfering 
with each other. 
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Assigning the Data Import Service Role 

 
Screenshot 40 - Assigning the Data Import Service role 

To assign the ‘Data Import Service Role’ select the appropriate option 
from the list of roles in the ‘Server Role Selection’ dialog. 

The server assigned this role uploads imported emails to the GFI 
MailArchiver Archive Stores. 

You can assign the ‘Data Import Service Role’ to multiple servers in 
the deployment. 
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Assigning the User Mailbox Synchronization Role 

 
Screenshot 41 - Assigning the Data Import Service role 

To assign the ‘User Mailbox synchronization Role’ select the 
appropriate option from the list of roles in the ‘Server Role Selection’ 
dialog. 

The User Mailbox Synchronization role is used to synchronize emails 
in a user mailbox between GFI MailArchiver and Microsoft Exchange 
Server. You can configure only one server to run the User Mailbox 
Synchronization Role in the deployment. 
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Assigning multiple roles to a server 

 
Screenshot 42 - Assigning multiple roles 

A GFI MailArchiver instance may be assigned more than one role. To 
assign the required roles, select the appropriate options from the list of 
roles in the ‘Server Role Selection’ dialog. 



 

72  Role-based Installations GFI MailArchiver for Exchange - Getting Started Guide 

Identifying the Central Configuration Service Role server 

 
Screenshot 43 - Identifying the Central Configuration Service Role server 

If you are assigning a role other than the ‘Central Configuration 
Service Role’ to a GFI MailArchiver instance, you are prompted to 
identify the server that has been assigned that role. 

Click Test connection to verify that the ‘Central Configuration Service 
Role’ server you specified is accessible. 
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Identifying the Data Collection Role server 

 
Screenshot 44 - Identifying the Data Collection Role server 

If you are assigning the ‘User Interface and Administration Role’ to a 
GFI MailArchiver instance, but not the ‘Data Collection Role’ to the 
same instance, you are prompted to identify the server with the ‘Data 
Collection Role’. 

Click Test connection to verify that the ‘Data Collection Role’ server 
you specified is accessible. 
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Identifying the Storage Role server 

 
Screenshot 45 - Identifying the Storage Role server 

If you are assigning a role other than the ‘Storage Role’ to a GFI 
MailArchiver instance, you are prompted to identify the server that has 
been assigned that role. 

Click Test connection to verify that the ‘Storage Role’ server you 
specified is accessible. 

Identifying the Search and Indexing Role server 

 
Screenshot 46 - Identifying the Search and Indexing Role server 
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If you are assigning a role other than the ‘Search and Indexing Role’ 
to a GFI MailArchiver instance, you are prompted to identify the server 
which has been assigned that role. 

Click Test connection to verify that the ‘Search and Indexing Role’ 
server you specified is accessible. 

6.3.1  Recommended deployment scenario 

 
Figure 4 - Deployment scenario 

This is the recommended scenario for a GFI MailArchiver distributed 
deployment. In this scenario, an organization will be deploying three 
GFI MailArchiver instances. Each instance is installed on a separate 
server, with each server fulfilling roles as shown in the following table: 

 

Server ID Role(s) 

 
 Data Collection 

 User Mailbox Synchronization 

 
 User Interface and Administration 

 
 Central Configuration Service 

 Storage 

 Search and Indexing 

 Data Import Service 

NOTE: To achieve maximum performance, assign the ‘Data Collection 
Role’ and the User Mailbox synchronization roles to a GFI 
MailArchiver instance residing directly on the Microsoft Exchange 
server with the journaling mailbox. 

These are the steps to follow for this deployment: 

1. Install GFI MailArchiver on each server. 

2. Execute the Deployment Manager Wizard on each of the three 
servers to assign roles to the GFI MailArchiver instances. The roles 
should be assigned in the order as listed in the ‘Executing the 
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Deployment Manager Wizard on each instance’ section of this 
chapter. Run the Deployment Manager Wizard in the order as shown 
in the following table: 

 

Server ID order Deployment Manager Wizard 

 
Run Wizard to assign the following roles: 

 Central Configuration Service 

 Storage 

 Search and Indexing 

 Data Import Service 

 
Run Wizard to assign the Data Collection role and User 
Mailbox synchronization roles. 

 
Run Wizard to assign the User Interface and 
Administration role 

 

3. Configure GFI MailArchiver through the management console, 
accessed from Server ID 2, which is the server with the User Interface 
and Administration role. 

6.3.2  Alternative scenario 

Another recommended scenario is to deploy servers with the following 
GFI MailArchiver roles: 

 Server 1: 

o Central Configuration Service 

o Storage 

 Server 2: 

o Search and Indexing 

 Server 3: 

o Data Collection 

o User Mailbox synchronization 

NOTE 1: To achieve maximum performance, assign the Data 
Collection role to a GFI MailArchiver instance residing directly on 
the Microsoft Exchange server with the journaling mailbox. 

NOTE 2: You can have multiple servers assigned with the Data 
Collection role. 

 Server 4: 

o User Interface and Administration 

NOTE: You can have multiple servers assigned with the User 
Interface and Administration role, enabling you to set up a web 
farm. 

 Server 5 (Temporary server): 

o Data Import Service 

NOTE: This temporary server can be used when past emails 
(before GFI MailArchiver was installed) from PST files will be 
imported into the Archive Stores. Importing past emails is normally 
a one-time process, thus the temporary nature of this server. 
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7.  Importing/Export emails 

7.1  Importing emails 

GFI MailArchiver enables you to extract emails from various email 
databases and to import them into the GFI MailArchiver Archive 
Stores. 

GFI MailArchiver can import emails from the following email 
databases: 

 Microsoft Exchange Mailboxes 

 PST files locally 

 PST files on the network 

 GFI MailArchiver 2 

 GFI MailEssentials 

For detailed instructions on how to import email data to GFI 
MailArchiver, refer to the GFI MailArchiver Manual available from: 

http://www.gfi.com/mar/mar6acmanual.zip 

7.2  Exporting emails 

 

GFI MailArchiver also enables you to export or restore multiple emails 
at a time through the GFI MailArchiver Bulk Export Tool. Through this 
tool, you can connect to a GFI MailArchiver installation, search for 
emails to export and export all of the emails in one go through a: 

• Restore to a specific email address  

• Download to a folder on disk in .eml or .msg format 

• Download to a PST file. 

The GFI MailArchiver Bulk Export Tool is useful when you want to 
export a set of emails that match specific search criteria, for example, 
to provide emails to satisfy a litigation support request. 

For detailed instructions on how to export email data from GFI 
MailArchiver, refer to the GFI MailArchiver Administration and 
Configuration guide available from: 

http://www.gfi.com/mar/mar6acmanual.zip 

http://www.gfi.com/mar/mar6acmanual.zip
http://www.gfi.com/mar/mar6acmanual.zip
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8.  Uninstalling GFI MailArchiver 

8.1  Uninstall GFI MailArchiver 

1. From the Control Panel select Add or Remove Programs or 
Programs and Features. 

2. Select GFI MailArchiver from the list displayed and click Remove or 
Uninstall. 

3. Follow on-screen instructions to uninstall GFI MailArchiver. 

8.2  Disabling journaling  

8.2.1  Microsoft Exchange Server 2000/2003 

1. Select Start ► Programs ► Microsoft Exchange ► System 
Manager. 

 
Screenshot 47 - Mailbox store node properties 

2. Expand Servers ► <Your Server name> ► Storage 
group, right click Mailbox Store node and select Properties. 
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Screenshot 48 - Enabling journaling on a Microsoft Exchange mailbox store 

3. From the General tab, unselect the Archive all messages sent or 
received by mailboxes on this store check box. Click OK to save 
settings. 

8.2.2  Microsoft Exchange Server 2007 

Disabling standard journaling 

1. Select Start ► All Programs ► Microsoft Exchange Server 2007 
► Microsoft Exchange Management Console. 
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Screenshot 49 - Configuring a Mailbox Database 

2. Expand Microsoft Exchange ► Server Configuration ► Mailbox 
node and click Properties from the Actions pane. 

 
Screenshot 50 - Mailbox Database properties 
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2. Unselect Journal Recipient option. 

3. Click OK to finalize setup. 

Disable standard journaling from the Microsoft Exchange 
Management Shell 

In the Microsoft Exchange Management Shell, use the following 
syntax to disable a journaling rule: 

Set-MailboxDatabase <Mailbox Database> -

JournalRecipient $Null 

Disable premium journaling 

1. Select Start ► All Programs ► Microsoft Exchange Server 2007 
► Microsoft Exchange Management Console. 

 
Screenshot 51 - Configuring Journaling rules 

2. Expand Organization Configuration ► Hub Transport node and 
select Journaling tab. 

3. Right click the journal rule to remove, and click Remove. 

4. Click Yes to confirm that you want to remove the journal rule. 

Disable premium journaling from the Microsoft Exchange 
Management Shell 

In the Microsoft Exchange Management Shell, use the following 
syntax to disable a journaling rule: 

Remove-JournalRule <journal rule name> 
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8.2.3  Microsoft Exchange Server 2010 

Disabling standard journaling 

1. Launch the Microsoft Exchange Management Console. 

 
Screenshot 52 - Configuring a Mailbox Database 

2. Expand Microsoft Exchange ► Organization Configuration ► 
Mailbox ► Database Management tab and select Properties from 
the Actions pane. 



 

84  Uninstalling GFI MailArchiver GFI MailArchiver for Exchange - Getting Started Guide 

 
Screenshot 53 - Mailbox Database properties 

2. Unselect Journal Recipient option. 

3. Click OK to finalize setup. 

Disable standard journaling from the Microsoft Exchange 
Management Shell 

In the Microsoft Exchange Management Shell, use the following 
syntax to disable standard journaling: 

Set-MailboxDatabase <Mailbox Database> -

JournalRecipient $Null 

Disable premium journaling 

1. Launch the Microsoft Exchange Management Console. 

2. Expand Organization Configuration ► Hub Transport node and 
select Journal Rules tab. 

3. Right click the journal rule to remove, and click Remove. 

4. Click Yes to confirm that you want to remove the journal rule. 

Disable premium journaling from the Microsoft Exchange 
Management Shell 

In the Microsoft Exchange Management Shell, use the following 
syntax to disable a journaling rule: 
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Remove-JournalRule <journal rule name> 
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9.  Troubleshooting 

9.1  Introduction 

The troubleshooting chapter explains how you should go about 
resolving any software issues that you might encounter. The main 
sources of information available to users are: 

 The manual - most issues can be solved by reading this manual. 

 GFI Knowledge Base articles accessible from the GFI website 

 Web forum 

 Contacting GFI Technical Support 
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9.2  Common Issues 
Issue encountered  Solution 

One of the following error 
messages is displayed while 
installing GFI MailArchiver: 

 Error 1720. There is a 
problem with this 
Windows Installer 
package. A script required 
for this install to complete 
could not be run. Contact 
your support personnel or 
package vendor. 

 Setup failed to launch 
installation engine: 
Access is denied. 

 Error installing 
Ikernel.exe, access is 
denied. 

1. Disable real-time scanning of anti-virus products or any other 
software scanning your machine real-time. 

2. Ensure that you do not have any software that automatically 
removes files from the TEMP directory. 

3. Log in the machine with the Domain Administrator account. 

4. Download and install the latest version of Windows Scripting Host & 
Windows Installer for your Windows Operating System from: 

http://www.microsoft.com/downloads/ 

5. Ensure that the following Microsoft Windows technologies are 
installed correctly and not corrupt: 

 Microsoft Windows Management Instrumentation (WMI) 

 Microsoft Windows Installer 

 Microsoft .Net Framework 

 Microsoft Data Access Components (MDAC) 

6. Ensure that the following system libraries located at 
<Windows\System32> are correctly registered:  

 Scrrun.dll 

 Actxprxy.dll 

 urlmon.dll 

 Oleaut32.dll 

 ole32.dll 

 Browseui.dll 

 Mshtml.dll 

 Shdocvw.dll 

 Shell32.dll   

To register a library with the operating system, perform the following 
steps:  

1. Click Start and select Run  

2. Type cmd.exe and click Enter. 

3. Type ‘regsvr32 <path & filename of dll>’  

Example: ‘regsvr32 c:\windows\system32\urlmon.dll’ 

Place the installation file in a temporary directory (Example C:\temp) 
on the machine where you are installing the GFI product.  

Also, check the Distributed Component Object Model (DCOM) 
permissions as explained in: 

http://support.microsoft.com/default.aspx?scid=kb;en-us;295278 

During installation, the 
following error is displayed:  

 The wizard was 
interrupted before GFI 
MailArchiver could be 
completely installed.  

 Your system has not been 
modified. To complete 
installation at another 
time, please run setup 
again. 

 The wizard was 
interrupted before GFI 
MailArchiver could be 
completely installed. 

Cause:  

Windows Scripting Host (WSH) is outdated or corrupted. 

Solution: 

Install latest version of Windows Scripting Host (WSH) and reboot the 
machine. WSH can be downloaded from: 

http://www.microsoft.com/downloads/details.aspx?FamilyId=C717D94
3-7E4B-4622-86EB-95A22B832CAA&displaylang=en 

 

GFI MailArchiver fails to 
authenticate when loading the 
web interface: Error 401. 

Cause:  

This error occurs when the IIS authentication method is not configured 
correctly on the GFI MailArchiver server. 

Solution: 

Verify the IIS authentication method used. 

IIS 6 

1. Navigate to Start ► Programs ► Administrative Tools ► 
Internet Information Services (IIS) Manager. 

http://www.microsoft.com/downloads/
http://support.microsoft.com/default.aspx?scid=kb;en-us;295278
http://www.microsoft.com/downloads/details.aspx?FamilyId=C717D943-7E4B-4622-86EB-95A22B832CAA&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=C717D943-7E4B-4622-86EB-95A22B832CAA&displaylang=en
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2.  Expand <web server name> ► Web Sites ► Default Web 
Site, right click MailArchiver and select Properties. 

3. Select Directory Security tab and under Authentication and 
access control, click Edit. 

4.  Check the Enable anonymous access check box. 

5. In the Authenticated access area, select the authentication 
method to use. Integrated Windows authentication is 
recommended. 

6. Click OK twice and close Internet Information Services (IIS) 
Manager. 

IIS 7 

1. Navigate to Start ► Programs ► Administrative Tools ► 
Internet Information Services (IIS) Manager. 

2.  Expand <web server name> ► Sites ► Default Web Site 
and select MailArchiver. 

3. In the Features view, double click Authentication. 

4. Click Anonymous Authentication and from the right pane 
select Enable.  

5. Select the authentication method to use and from the right pane 
click Enable. Windows Authentication is recommended. 

6. Close Internet Information Services (IIS) Manager. 

GFI MailArchiver fails to 
authenticate when loading the 
web interface: Error 4000. 

Cause: 

This error occurs when another application is installed on the GFI 
MailArchiver server, which may be using the same ports required by 
GFI MailArchiver. 

Solution: 

Verify that the default ports used by GFI MailArchiver are not used by 
other software: 

1. In GFI MailArchiver server, launch Command Prompt. 

2. In the command line, type netstat -abn >C:\netstat.txt. A text file 
named netstat.txt is created in C:\.  

3. Open netstat.txt and locate the following entries under Proto 
column: 

 TCP 0.0.0.0: 8014 - [MArc.Core2.exe] 

 TCP 0.0.0.0: 8017 - [MArc.Core.exe] 

 TCP 0.0.0.0: 8018 - [MArc.Store.exe] 

 TCP 0.0.0.0: 8019 - [MArc.Search.exe] 

 TCP 0.0.0.0: 8020 - [MArc.MAIS.exe] 

If any of the ports do not correspond with the executable files, the GFI 
MailArchiver executable file must be configured to use a different port. 
To change a default port: 

1. Navigate to Start ► Run and type services.msc. 

2. Stop all GFI MailArchiver services. 

3. Navigate to the GFI MailArchiver installation folder and backup the 
following files: 

 ..\Core\bin\MArc.Core.Remoting.exe.config  

 ..\Core\bin\MArc.UMPolling.ExPolling.exe.config  

 ..\Core2\bin\Marc.Core2.exe.config  

 ..\Core2\bin\Marc.Core2.Remoting.exe.config  

 ..\Mais\bin\MArc.MAIS.Remoting.exe.config  

 ..\Mais\bin\MArc.MAIS.exe.config  

 ..\Search\bin\MArc.Search.Remoting.exe.config  

 ..\Search\bin\MArc.Search.exe.config  

 ..\Store\bin\MArc.Store.Remoting.exe.config  

 ..\Store\bin\MArc.Store.exe.config  

 ..\ASPNET\remoting.config 

4. Open each .config file listed in step 3 in a text editor, search for the 
port number to change and replace by a new port number. 

Example: Search for 8017 and replace by 8117. 

NOTE: Ensure that the new port number is not used by any other 
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application. 

5. When changes are made in a .config file, save the file with encoding 
set to UTF-8. 

6. Click Save to apply changes. 

7. When all .config files are updated, restart the GFI MailArchiver 
services stopped in step 2. 

8. Repeat netstat test in command prompt to confirm that the GFI 
MailArchiver is now using the new ports. 

GFI MailArchiver fails to load 
ASP.NET. Error 404. 

Cause 1: 

ASP.NET is not registered with IIS Web Server. 

Solution 1: 

To resolve this issue, refer to section ASP.NET settings in this manual. 

Cause 2: 

ASP.NET is blocked by the IIS Manager. 

Solution 2: 

Ensure that ASP.NET is allowed by Internet Information Services (IIS) 
Manager. 

IIS 6 

1. Navigate to Control Panel ► Administrative Tools ► 
Internet Information Services (IIS) Manager. 

2. Expand the local computer node and select Web Service 
Extensions.  

3. In the right pane, right click ASP.NET v2.0.xxxxx and select 
Allow. 

IIS 7 

1. Navigate to Control Panel ► Administrative Tools ► 
Internet Information Services (IIS) Manager. 

2. Select the local computer node and from the Features View 
pane launch ISAPI and CGI Restrictions. 

3. In the Features View pane, right click ASP.NET v2.0.xxxxx and 
select Allow. 

 

9.3  Knowledge Base 

GFI maintains a Knowledge Base, which includes answers to the most 
common problems. If you have a problem, please consult the 
Knowledge Base first. The Knowledge Base always has the most up-
to-date listing of technical support questions and patches. To access 
the Knowledge Base, visit http://kbase.gfi.com/. 

9.4  Web Forum 

User to user technical support is available via the web forum. The 
forum can be found at: http://forums.gfi.com/. 

9.5  Contact technical support 

If you have referred to this manual and our Knowledge Base articles, 
and you still cannot solve issues with the software, contact the GFI 
Technical Support team by filling in an online support request form or 
by phone. 

 Online: Fill out the support request form on: 
http://support.gfi.com/supportrequestform.asp. Follow the 
instructions on this page closely to submit your support request. 

 Phone: To obtain the correct technical support phone number for 
your region please visit: http://www.gfi.com/company/contact.htm. 

NOTE: Before you contact our Technical Support team, please have 
your Customer ID available. Your Customer ID is the online account 

http://kbase.gfi.com/
http://forums.gfi.com/
http://support.gfi.com/supportrequestform.asp
http://www.gfi.com/company/contact.htm
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number that is assigned to you when you first register your license 
keys in our Customer Area at: http://customers.gfi.com. 

We will answer your query within 24 hours or less, depending on your 
time zone. 

9.6  Build notifications 

We strongly suggest that you subscribe to our build notifications list. 
This way, you will be immediately notified about new product builds. 
To subscribe to our build notifications, visit: 

http://www.gfi.com/pages/productmailing.htm. 

http://customers.gfi.com/
http://www.gfi.com/pages/productmailing.htm
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